[GH #5456] Columns lose data when manually moved over hidden columns

Tags: #<Tag:0x00007fa9998d7760> #<Tag:0x00007fa9998d75d0>

The issue that i am seeing is that when ever i drag a column over a hidden column, values those columns and/or the column i am dragging disappears. I saw another topic post from 2016 where someone else was dealing with the same issues and it was stated that the next release had a fix for it. Is there a setting or a setting order that I am missing when trying to hide columns and reorder them?

I created this fiddle to demo an issue i am having with the hidden columns setting. I am dynamically adding columns with the updateSetting method and i have turned on the hidden columns and the manualMoveColumns

https://jsfiddle.net/stephenB/wy9f40pg/24/

Thanks

Hi Stephen,

Can you tell me what are the steps to take to replicate the issue and what was the number of the fixed bug you saw? Maybe it is a ‘regression’.

sure, click on the load button to load the data into the grid with the updateSettings method. Once that loads, drag column M between P and Q, notice that you are dragging over a couple hidden columns. After you let go, some of the columns lose data when the cells shift left… If you drag it or another column back over the column with the missing data, the data for that column might come back or you might compound the issue and lose more data.

here is a link to the topic i saw that showed the issue was fixed. The version was said to be 1.3.2

thanks

Thank you for sharing the bug scenario.

I have replicated the issue. I will investigate this subject and share my thought as soon as possible.

Thanks, Aleksandra.

I have simplified the example https://jsfiddle.net/handsoncode/dtqzr4jL/ but it still works the same. Possibly wrong indexes are shared between the plugins.
I have reported the issue on the Github board at https://github.com/handsontable/handsontable/issues/5456

Thanks, Aleksandra. I was thinking that it was an index problem as well. where the indexes for the hidden columns are not getting updated with the move. Do you have an SLA for when you think the issue will be resolved?

We have discussed this on emails but I share an information for all the users that are tracking this issue.

We are planning to schedule this fix in the November’s milestone.

1 Like

Hi, any update of this problem? Cheers

I do not have any information about this topic yet. Here’s a list of issue that we are working on https://github.com/handsontable/handsontable/issues/6465

Hi, Still I am facing this issue. When it will be solved??

Hi @suman.dutta

the following is explained here https://github.com/handsontable/handsontable/issues/5598 and will be fixed in the next version (possibly 8.0.0-beta2).

1 Like