[GH #7160] [8.1.0] Uncaught Error: Incorrect value of the columnsRenderCalculator

Tags: #<Tag:0x00007fbe90155fd0> #<Tag:0x00007fbe90155d00>

Hi, I’ve started seeing this error with v8.1 (not sure about v8.0 but wasn’t an issue with v7.4.2). The issue leads to blank table in certain situations. I’ve managed to get a fairly minimal repro of it in this fiddle.

Note that it can be hard to reproduce the error with this fiddle. Sometimes I have to restart the fiddle and wiggle the scroll bar for quite a while before the error occurs. Other times it’s pretty easy to trigger. Maybe it depends on the expression on your face :wink:

Hi @andrew.jerrim

I was able to replicate the issue. Please tell me if it works well when you change data from null to an empty array [] ? It seems to work well on my Chrome 86.

Hi @aleksandra_budnik, I can still trigger the error if data = [], but it is still an unreliable repro for me (also in Chrome 86).

Oh yes… I can see it now.

20

I got too excited and did not pull the scrollbar to the maximum left.

Could you check if replacing

columns: [0, 1, 2]

with

columns: [1, 2]

changes anything?

I tried removing column 0 from the hidden columns, and was unable to observe the error.

However that does not reflect our use case, which involves hiding all the columns nested under a heading. If we don’t hide all of them, then the nesting definition is wrong.

I should also mention that in our use case the table cells are not rendered after the error occurs.

I’m still on the case trying some different approaches and it seems that it also works fine (no blank space) when we fill the table with data http://jsfiddle.net/AMBudnik/ezqk7rb4/ Then we can keep all the hiddenColumns as they were set up in the first place.

Following that rule, I commented out the helper data and added minCols, and set it to 28 (9 x 3 of {label: 'Group 1', colspan: 3}). This http://jsfiddle.net/AMBudnik/5tg390rd/ seems to do the job and avoid removing or changing any of your previous settings.

Hi @aleksandra_budnik , I can still see the issue when I run both of those new fiddles.

Here’s another one which often shows the blank columns when you drag back to the left: http://jsfiddle.net/andrew_j/wv8cax6d/126/

True.

35

One question - have you tried using renderAllRows: true? Did that change anything?

Yes, I had tried renderAllRows: true. It may reduce the probability of occurrence, but it still errors from time to time unfortunately.

Also I should mention that we can see the issue occur in our prototype app by just clicking a check-box. However, I haven’t been able to reproduce that in a fiddle.

Sorry for the delay @andrew.jerrim

I’ve asked my colleague to check this on his device. I will update you later this week.

Hi @andrew.jerrim

I am afraid that we need to wait for this main regression bug to be solved first https://github.com/handsontable/handsontable/issues/7160 as it relates to the settings you use in the project and causes the same error.
I will make sure to inform you right after we publish the fix.

ok, thanks for the update