Table returns empty data if to filter certain columns

Tags: #<Tag:0x00007fa99618e240>

Hello everyone!

When I’m trying to filter certain columns via DropDownMenu, after applying filter (any one, “Contains”, “More than” etc.), the output is totally empty, only column headers remain. After setting filter to “None”, all filtered data returns just fine.

I’ve noticed an interesting pattern: if I try to double click a cell with data at the ‘broken’ column, then after initiating edit mode, the value inside the cell becomes empty, and it remains so after exiting edit mode, though returns after reloading the table (I’m not losing any data and that’s just fine, but it seems like the filter doesn’t see these values and consider them as null). The sound (working) columns don’t act like this, the cell values in them do not get nullified both at entering and exiting edit mode.

Wish I could provide a demo, but the situation is that while HOT instance is in browser, it filters all columns properly, but inside of our software (Power BI, the table is being set up by means of TypeScript) it doesn’t.

  • Handsontable version: 7.1.1
  • Operating System: Windows 10

Hey @n.schipkov

can you record it or share a demo where the issue can be replicable? It seem to work fine in our official demo

Hello @aleksandra_budnik,

Thank you for responding, but I managed to do it myself. I don’t know the reason, but the filter wouldn’t work if column header names contain dots. Without them, columns began filtering just fine :slight_smile:

Thank you for the quick update. I will check the dot issue… or maybe you could share the name that did the trouble? I tried to play with filters here and it works well.

Well, there’s not much to say - the error would appear if there were dot(s) in column headers. If you mean filter’s name, none of them worked. After deleting dots, filtering worked again

Ohh OK. I will check it out. Thanks :slight_smile:

1 Like