[#4172] Autocomplete cell type is cropped when used with scrolling tables

Tags: #<Tag:0x00007fd2c75d5fd8> #<Tag:0x00007fd2c75d5df8>

It appears that the built-in autocomplete cell editor type does not work properly with scrolling tables.

Here it is in a normal table:

image

Here it is in a scrolling table:

image

This is because the dropdown component is attached to a parent IN the table, vs OUTSIDE the table, like the Pikaday editor does.

Is there a way to solve this using existing options, or should we extend the existing editor and override the attachment / positioning functions in lieu of a fix?

Thanks,
Dave

Hey Dave,

Can you please paste the exampel to this topic https://github.com/handsontable/handsontable/issues/4172 ?

Done :slight_smile:

Thank you :slight_smile:

So I took the last few days to build a custom autocomplete editor, very pleased with the results!

Screenshot:

Async options:

Sync options:

The custom editor tutorial was a great starting point even though it is quite a daunting document.

This uses features from both the password and select examples, so just my luck!

I have some ideas how it the doc could be made better; I’ll post something in the docs repo.

Cheers!

Nice… What was the hardest thing to do? Did you use any hacks or it’s all fine you won’t get any issues while updating?

I have some ideas how it the doc could be made better; I’ll post something in the docs repo.

thanks!