Angular-wrapper with handsontable8.0.0

Greeting,
Is actual angular wrapper ("@handsontable/angular": “^5.1.0”) is compatible with HOT 8.0.0 beta (“handsontable”: “^8.0.0-beta.1”) ?
Because I have a lot of weird issue (cf. attached file)

Thank you for the report. I will check it out.

Actually, I saw the article of Anna Cieślik.

https://handsontable.com/blog/articles/2019/11/handsontable-8-0-0-beta-1-released
that explain all breaking change.

But I still don’t know if it’s compatible with the actual angular wrapper.

I’ll be waiting for your futur answer about that.

Here is a demo with the latest Handsontable for Angular and Handsontable 8.0.0.-beta1.
https://jsfiddle.net/AMBudnik/7munagwd/ so I’m afraid that it might be something in your settings

Indeed, It is definitely something with my configuration.
But unfortunately, I can’t work with a beta version.
So I’ll wait for the 8.0.0 release.

Thank you again.

On Monday we are planning to publish 7.3.0 and then we’ll be able to test 8.0.0-beta1 a bit more and publish it as a stable version.

Hey @alexandre.quere

My colleague gave me a tip that the issue you’re having might be related to some breaking changes that happened in 8.0.0-beta1. All those hooks that are listed in the image are removed in the beta version. Your .ts file might be looking for them.

Hello @aleksandra_budnik,

You are totally right, I indeed saw this in the article of Anna.

Actually, I saw the article of Anna Cieślik.
https://handsontable.com/blog/articles/2019/11/handsontable-8-0-0-beta-1-released
that explain all breaking change.
But I still don’t know if it’s compatible with the actual angular wrapper.
I’ll be waiting for your futur answer about that.

Thank you again for your reactivity and I’ll be waiting for the 8.0.0 release. :grin:

1 Like