Disable comma as decimal delimiter

Tags: #<Tag:0x00007fd2bda51260>

In the docs for the number column type, it says that commas are effectively the same as decimals:

For us, this behaviour is undesirable, as commas mean 100,000s.

I presume a beforeChange hook is the way to handle this?

Hey Dave,

Sorry but I do not understand the request :baby: (maybe cause it’s before 8:00 am here)

Do you want to get rid of the decimals and round the value or change chars (patterns) for decimals.

Sorry!!!

The current behaviour is:

  • enter a number with commas, say 100,00 and it is parsed to 100.00 (100)

We want:

  • enter a number with commas, say 100,000 and it is parsed to 100000 (100,000)

The links I posted are HoT docs, which explain this as a “feature” for “numeric” field types.

We want to disable it.

How do we do this?

I do not see any pattern for achieving this conversion so the only way would be to use a custom renderer.

OK, that’s super-easy. Thanks!