Handsontable not rendering properly: error n is not a function

Tags: #<Tag:0x00007fee3623f178>

Hello,

Everything was working great until today. In all of my projects with Handsontable, I keep getting Uncaught TypeError: n is not a function in handsontable.min.js. Table is rendering only till certain row, on scroll it gives this error, on update it gives this error, basically on every action. Do you maybe know why is this happening?

Thanks

Hi @katarina.kelam22

Did you change anything in the code or update the version of Handsontable? Handsontable does not upload any updates itself, so it had to be an in-app change.

ps. This

Uncaught TypeError: n is not a function in handsontable.min.js.

is an error of a minified .js version. Can you load the handsontable.js or handsontable.full.js and resend the error message (it should print more details).

Hi, so I didn’t update the version, but I was working on the code implementing nested rows, and this just started appearing at one point. At first I thought I did something wrong, but the curious thing is that the same error appeared in a version that was deployed few days ago and completely working fine.

We have 4 issues on GitHub related to getting errors while using nestedRows. Please check if any of those issues is the one you get https://github.com/handsontable/handsontable/issues?q=is%3Aopen+is%3Aissue+label%3A"Nested+rows"+error

If not, I would need to ask for a demo or for the error message from a non-minified version of Handsontable.

Hi Aleksandra, we rolled back to a previous version and it solved the issue at this point. The nested rows implementation also works now. Thanks for your help

Thank you for the update. Wen, you’ll be ready to get back to this issue, please contact me at support@handsontable.com as due to security reasons, it’s always better to have the ability to update to a newer version of any software.