Hidding columns angular 8 handsontable 6.2.2

Tags: #<Tag:0x00007fd2cd119728>

Hi I have another issue with handsontable 7.2.2 in which would take me a lot of time to create an example.

A temporary solution to this is to downgrade handsontables to 6.2.2 but when I do this hidden columns is an issue with angular 8. Columns are still displayed i.e.

hiddenColumns: { columns: this.hiddenColumns },
or
hiddenColumns: { columns: [0,1] },

Please could you tell me the compatibility of handsontable 6.2.2 with the different angular versions and if there is a solution to this.

https://handsontable.com/docs/6.2.2/Options.html#hiddenColumns

If this could be made compatible then it would give me time to produce an example of the other issue.

“dependencies”: {
@angular/animations”: “8.2.13”,
@angular/cdk”: “^8.0.0”,
@angular/common”: “8.2.13”,
@angular/compiler”: “8.2.13”,
@angular/core”: “8.2.13”,
@angular/forms”: “8.2.13”,
@angular/platform-browser”: “8.2.13”,
@angular/platform-browser-dynamic”: “8.2.13”,
@angular/platform-server”: “8.2.13”,
@angular/router”: “8.2.13”,
@nguniversal/module-map-ngfactory-loader”: “^8.0.0-rc.1”,
“aspnet-prerendering”: “^3.0.1”,
“bootstrap”: “^4.3.1”,
“chart.js”: “^2.8.0”,
“core-js”: “^2.5.4”,
“font-awesome”: “^4.7.0”,
“handsontable”: “^6.2.2”,
“jquery”: “3.3.1”,
“lodash”: “^4.17.10”,
“ngx-spinner”: “^8.0.3”,
“ngx-treeview”: “^6.0.2”,
“popper.js”: “^1.14.3”,
“primeicons”: “^2.0.0”,
“primeng”: “^8.1.1”,
“quill”: “^1.3.7”,
“rxjs”: “^6.5.3”,
“sheetclip”: “0.3.0”,
“tslib”: “^1.9.0”,
“zone.js”: “~0.9.1”
},
“devDependencies”: {
@angular-devkit/build-angular”: “~0.803.17”,
@angular/cli”: “^8.3.17”,
@angular/compiler-cli”: “8.2.13”,
@angular/language-service”: “^8.2.13”,
@types/jasmine”: “~2.8.6”,
@types/jasminewd2”: “~2.0.3”,
@types/node”: “~8.9.4”,
“codelyzer”: “^5.0.1”,
“jasmine-core”: “~2.99.1”,
“jasmine-spec-reporter”: “~4.2.1”,
“karma”: “^3.0.0”,
“karma-chrome-launcher”: “~2.2.0”,
“karma-coverage-istanbul-reporter”: “~1.4.2”,
“karma-jasmine”: “~1.1.1”,
“karma-jasmine-html-reporter”: “^0.2.2”,
“typescript”: “^3.4.5”
},
“optionalDependencies”: {
“node-sass”: “^4.9.3”,
“protractor”: “~5.1.2”,
“ts-node”: “~5.0.1”,
“tslint”: “~5.9.1”
}

Ben, we would need to have any demo where the issue can be replicable. Or (if you use only the Angular wrapper (latest) + want to load Handsontable latest) your settings so we’ll be able to build the example.

Hi,

You still have an issue, but could you close this as I have found a temporary hack/fix for my issue with the library 7.2.2.

If you wish I can close your topic but if you have found anything that is not reported on our Github board I would really appreciate a demo. It is always better to get an offcial fix that will by supported in future versions.