Number of rows saving issue

Tags: #<Tag:0x00007fd2ce545d28>

Hi,
I have two points that i cant solve on my own.
1)–> I have a table with multiple rows. each row is provided with save button at the end and an hidden column with row id in the front(starting column). If i save the data for the first time it will get saved into my db and table is loaded with the data i.e what i saved in database table. and if i again click on the same row button the row will be updated based on row id(hidden field). i have no issues in saving and updating the data for limited rows. If i have more than 20 rows the newly inserting row is getting the previous row id and data is updating instead of saving(because of the presence of id).
2)–>I have some rows with comments for columns, but sometimes when i place the cursor the comment is showing at multiple places
can you please help me to find the solution for the poins mentioned above

Hi @srinivas.sri.t

It would be very hard to help without a demo as you have some more complicated logic implemented. Can you share a demo where the issues can be replicable? Of course you’d need to replace the server calls with some fake loading function.

Sure, i will share you details in a short time @aleksandra_budnik

Hi @aleksandra_budnik
Please find the attachment

So when i enter details in a new row which doesnt have an row id and when i click on save button it will be saved(service callled on button click) and the saved data is loaded into handsontable with rowid . if i again click save button on any of the rows in the table it will be updated based on rowid. its working fine for few rows, If i have more rows for the new row when i entered details and click on the save button(on click i’m getting details of row by getDataAtRow ) i’m getting some random row id or previous row id for id column(which is hidden field after number column and before blank column seen in attachment) which actually should be empty.
can you please help me

Do you move, filter or sort the rows? Only then the indexes visual !== visual.

, If i have more rows for the new row

this is something that I don’t understand. Do you load some extra rows programmatically?

Hii @aleksandra_budnik,
Let me explain you in clear.
So when i started entering data and click on save button it will insert record into table in my database.In UI when i modify details in a row and click on the save button it will update the record of a table in DB based on rowid. initially table row will have no id, after successfull saving of data in table i will fetch the records from my table in DB and fill the hot table in UI. There is no disturbance of functionality if i have limited rows(20 or 23) .If more than that (20 above rows) im getting rowid for a new row which is to be inserted in table instead it is updating the previous record because of rowid (now i think you can understand the scenario).

No i dont add extra rows programmatically. User will enter the data manually

Yes, I understand but this is something new for me. I haven’t heard about a similar issue. I think that it might be related to rendering and the viewport/container size but I’d need to have an actual demo and be able to debug it.
Have you tried to use renderAllRows: true on the table?

I havent used renderAllRows,
the save buttons which are at the end of the row are created using renderer.

function renderButtons(instance, td, row, col, prop, value, cellProperties) {
td.innerHTML = “Save”;
}
I tried using renderAllRows it worked i tested by saving some 50 rows. Does renderButtons effect the performance.
Thanks @aleksandra_budnik

The renderAllRows will affect the performance of loading but will save the user time while scrolling. It forces the table to load all the rows at once.
If you do not work on all the rows but need to keep the buffer you can try to use different values in the viewportRowRenderingOffset.

Thanks @aleksandra_budnik, the information helped me.

Great :slight_smile: I’m happy to hear that.

Hi @aleksandra_budnik, As i mentioned in 2nd point that comments appearing twice. can you please check this attachment

It looks like a position bug. If you use some CSS frameworks you could check if the issue is still present after commenting out their code.
If that won’t help please share a demo (perfectly in JSFiddle) where I’d be able to replicate this bug.

I think that we can close this topic as there’s no update for 13 days.