Problem with the scrollbars and fixed height & width

Tags: #<Tag:0x00007fd2cd14a2d8>

https://jsfiddle.net/z07de6vx/9/

The above table might look fine if the user uses the chrome browser from the default macbook.

However,

  1. if user set ‘System Preferences > General > Show scroll bars’ to ‘Always’ instead of the default value of ‘Automatically based on mouse or trackpad’,
  2. if the user has Windows OS that usually always show scroll bars by default,
    => then both vertical and horizontal scrollbars will appear and almost impossible to see the editing cell with scrollbar space.

Any suggestions or fixes for this?

Hey @george1

we had a discussion on this topic 2 weeks ago on a Devs meeting. This subject is really difficult as we cannot force someone to use some system settings. Some of the users even do not know what settings do they use.

Do you, as a developer, have any suggestions?

Before I moved to the licensed version, and used free community version, I had a custom way to hide and show. Basic idea was that since Handsontable already use multiple div of ht_clone to setup, I added one more wrapper div to just do the scroll(always shown and float outside of table) and force hide the scrollbars(-webkit-scrollbar, etc.) from ht_master.

I am not sure this is the best way, but that could be a one way. :slight_smile:

Hey George,

Thank you for sharing your tips.

I had a discussion with one of our developers and he told me that we do not have bigger chances to get this done now. However, if that is too pesky you can wrap the Handsontable with an iframe and use the iframe’s size to build the scroll. But that is also a hack…

1 Like