Editing long texts

Tags: #<Tag:0x00007ff4db57d348>

Hello,

I have an issue with editing Long texts.
Here’s the fiddle: http://jsfiddle.net/41x69v70/9/

When you go and try to edit cell C1 (via double-click, F2, Enter key - it doesn’t matter), no scrollbar appears.
It only appears when I click into the editor and press a key on the keyboard (e.g. arrow key).

Is there any solution to this?

Thanks,
Andraz

Hi @andraz.podobnik

It is known issue, and we have it reported in our repository. I’ll let you know when we fix it.

1 Like

Hi @andraz.podobnik

I’m happy to inform you that with the latest release of Handsontable v. 14.0 the issue is fixed.

You can check it in this example: https://jsfiddle.net/nexczq7j/1/

Let me know if this behavior is now how you expected it to work.

Hi @adrian.szymanski,

I’m not sure that it’s fixed.
Please see this example (https://jsfiddle.net/majh1x5w/) and try to edit cell C1. After going to “edit” mode, there’s no scrollbar initially (as I wrote in my comment above).

Can you reproduce this?

Thanks,
Andraz

Hi @andraz.podobnik

You are right, the mentioned issue fixed it only partially and didn’t take this case into account. I’ll add your specific case, and I hope it will also be fixed soon.

Hi @andraz.podobnik

Just wanted to let you know that we released Handsontable 14.2 including the fix for this issue. Please, check it and let me know if the issue is gone.

Hi there,

just tried with Handsontable 14.2 and the issue is fixed :+1:
https://jsfiddle.net/gqe8wv0z/1/

Thanks.

Hi @andraz.podobnik

Thank you for the update. I’m closing this topic then.